<!DOCTYPE html>
<html class="no-js mh-one-sb" lang="en-US">
<head>
<meta charset="UTF-8"><script type="text/javascript">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</script>
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://ansonrecord.com/xmlrpc.php" />
<title>Drawing a parallel between &#8216;Sound of Music&#8217; and impeachment hearing | Anson Record</title>

<!-- The SEO Framework by Sybre Waaijer -->
<meta name="description" content="I watched the impeachment hearings. I heard the indisputable testimony of patriotic professionals whose integrity had never been questioned, and who had never&#8230;" />
<meta property="og:image" content="https://s24519.pcdn.co/wp-content/uploads/2018/02/cropped-ansonlogo-2.png" />
<meta property="og:image:width" content="300" />
<meta property="og:image:height" content="86" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Drawing a parallel between &#8216;Sound of Music&#8217; and impeachment hearing | Anson Record" />
<meta property="og:description" content="I watched the impeachment hearings. I heard the indisputable testimony of patriotic professionals whose integrity had never been questioned, and who had never been insultingly criticized until they&#8230;" />
<meta property="og:url" content="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing" />
<meta property="og:site_name" content="Anson Record" />
<meta property="article:publisher" content="https://www.facebook.com/pages/Anson-Record/180849995282535" />
<meta property="article:published_time" content="2019-12-18T12:12+00:00" />
<meta property="article:modified_time" content="2019-12-18T18:55+00:00" />
<meta property="og:updated_time" content="2019-12-18T18:55+00:00" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@TheAnsonRecord" />
<meta name="twitter:title" content="Drawing a parallel between &#8216;Sound of Music&#8217; and impeachment hearing | Anson Record" />
<meta name="twitter:description" content="I watched the impeachment hearings. I heard the indisputable testimony of patriotic professionals whose integrity had never been questioned, and who had never been insultingly criticized until they&#8230;" />
<meta name="twitter:image" content="https://s24519.pcdn.co/wp-content/uploads/2018/02/cropped-ansonlogo-2.png" />
<meta name="twitter:image:width" content="300" />
<meta name="twitter:image:height" content="86" />
<link rel="canonical" href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing" />
<script type="application/ld+json">{"@context":"https://schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https://ansonrecord.com/","name":"Anson Record"}},{"@type":"ListItem","position":2,"item":{"@id":"https://ansonrecord.com/category/opinion","name":"Opinion"}},{"@type":"ListItem","position":3,"item":{"@id":"https://ansonrecord.com/category/opinion/letters","name":"Letters"}},{"@type":"ListItem","position":4,"item":{"@id":"https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing","name":"Drawing a parallel between &#8216;Sound of Music&#8217; and impeachment hearing"}}]}</script>
<!-- / The SEO Framework by Sybre Waaijer | 11.07ms meta | 3.81ms boot -->

<link rel='dns-prefetch' href='//ansonrecord.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Anson Record &raquo; Feed" href="https://ansonrecord.com/feed" />
<link rel="alternate" type="application/rss+xml" title="Anson Record &raquo; Comments Feed" href="https://ansonrecord.com/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="Anson Record &raquo; Drawing a parallel between &#8216;Sound of Music&#8217; and impeachment hearing Comments Feed" href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/feed" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s24519.pcdn.co\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://s24519.pcdn.co/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='simple-staff-list-css'  href='https://s24519.pcdn.co/wp-content/plugins/simple-staff-list/public/css/simple-staff-list-public.css?ver=2.2.0' type='text/css' media='all' />
<link rel='stylesheet' id='vfb-pro-css'  href='https://s24519.pcdn.co/wp-content/plugins/vfb-pro/public/assets/css/vfb-style.min.css?ver=2019.05.10' type='text/css' media='all' />
<link rel='stylesheet' id='megamenu-css'  href='https://s24519.pcdn.co/wp-content/uploads/maxmegamenu/style.css?ver=1d4831' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://s24519.pcdn.co/wp-includes/css/dashicons.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='mh-magazine-css'  href='https://s24519.pcdn.co/wp-content/themes/mh-magazine/style.css?ver=3.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='mh-font-awesome-css'  href='https://s24519.pcdn.co/wp-content/themes/mh-magazine/includes/font-awesome.min.css' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='mh-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Open+Sans:300,400,400italic,600,700' type='text/css' media='all' />
<script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript' src='https://s24519.pcdn.co/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://s24519.pcdn.co/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://s24519.pcdn.co/wp-content/themes/mh-magazine/js/scripts.js?ver=3.8.3'></script>
<link rel='https://api.w.org/' href='https://ansonrecord.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://ansonrecord.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s24519.pcdn.co/wp-includes/wlwmanifest.xml" /> 
<link rel="alternate" type="application/json+oembed" href="https://ansonrecord.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fansonrecord.com%2Fopinion%2Fletters%2F8984%2Fdrawing-a-parallel-between-sound-of-music-and-impeachment-hearing" />
<link rel="alternate" type="text/xml+oembed" href="https://ansonrecord.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fansonrecord.com%2Fopinion%2Fletters%2F8984%2Fdrawing-a-parallel-between-sound-of-music-and-impeachment-hearing&#038;format=xml" />
<style type="text/css">
.mh-widget-layout4 .mh-widget-title { background: #0066bf; background: rgba(0, 102, 191, 0.6); }
.mh-preheader, .mh-wide-layout .mh-subheader, .mh-ticker-title, .mh-main-nav li:hover, .mh-footer-nav, .slicknav_menu, .slicknav_btn, .slicknav_nav .slicknav_item:hover, .slicknav_nav a:hover, .mh-back-to-top, .mh-subheading, .entry-tags .fa, .entry-tags li:hover, .mh-widget-layout2 .mh-widget-title, .mh-widget-layout4 .mh-widget-title-inner, .mh-widget-layout4 .mh-footer-widget-title, .mh-widget-layout5 .mh-widget-title-inner, .mh-widget-layout6 .mh-widget-title, #mh-mobile .flex-control-paging li a.flex-active, .mh-image-caption, .mh-carousel-layout1 .mh-carousel-caption, .mh-tab-button.active, .mh-tab-button.active:hover, .mh-footer-widget .mh-tab-button.active, .mh-social-widget li:hover a, .mh-footer-widget .mh-social-widget li a, .mh-footer-widget .mh-author-bio-widget, .tagcloud a:hover, .mh-widget .tagcloud a:hover, .mh-footer-widget .tagcloud a:hover, .mh-posts-stacked-item .mh-meta, .page-numbers:hover, .mh-loop-pagination .current, .mh-comments-pagination .current, .pagelink, a:hover .pagelink, input[type=submit], #infinite-handle span { background: #0066bf; }
.mh-main-nav-wrap .slicknav_nav ul, blockquote, .mh-widget-layout1 .mh-widget-title, .mh-widget-layout3 .mh-widget-title, .mh-widget-layout5 .mh-widget-title, .mh-widget-layout8 .mh-widget-title:after, #mh-mobile .mh-slider-caption, .mh-carousel-layout1, .mh-spotlight-widget, .mh-author-bio-widget, .mh-author-bio-title, .mh-author-bio-image-frame, .mh-video-widget, .mh-tab-buttons, textarea:hover, input[type=text]:hover, input[type=email]:hover, input[type=tel]:hover, input[type=url]:hover { border-color: #0066bf; }
.mh-dropcap, .mh-carousel-layout1 .flex-direction-nav a, .mh-carousel-layout2 .mh-carousel-caption, .mh-posts-digest-small-category, .mh-posts-lineup-more, .bypostauthor .fn:after, .mh-comment-list .comment-reply-link:before, #respond #cancel-comment-reply-link:before { color: #0066bf; }
</style>
<!--[if lt IE 9]>
<script src="https://s24519.pcdn.co/wp-content/themes/mh-magazine/js/css3-mediaqueries.js"></script>
<![endif]-->
<link rel="icon" href="https://s24519.pcdn.co/wp-content/uploads/2018/02/cropped-anslog-32x32.jpg" sizes="32x32" />
<link rel="icon" href="https://s24519.pcdn.co/wp-content/uploads/2018/02/cropped-anslog-192x192.jpg" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://s24519.pcdn.co/wp-content/uploads/2018/02/cropped-anslog-180x180.jpg" />
<meta name="msapplication-TileImage" content="https://s24519.pcdn.co/wp-content/uploads/2018/02/cropped-anslog-270x270.jpg" />
		<style type="text/css" id="wp-custom-css">
			.attachment-mh-magazine-slider{
height: 300px !important;
width: auto !important;
}
.mh-posts-large-thumb img {
max-height:300px;
    width: auto;
}
.mh-thumb-icon{
	text-align:center;
	background-color:black;
}

@media only screen and (max-width: 600px) {
	div.adblade-dyna.zone-13366 {
		display: none;
	}
}		</style>
		<style type="text/css">/** Mega Menu CSS: fs **/</style>
</head>
<body data-rsssl=1 id="mh-mobile" class="post-template-default single single-post postid-8984 single-format-standard wp-custom-logo mega-menu-mh-main-nav mh-boxed-layout mh-right-sb mh-loop-layout1 mh-widget-layout1" itemscope="itemscope" itemtype="http://schema.org/WebPage">
<div class="mh-container mh-container-outer">
<div class="mh-header-nav-mobile clearfix"></div>
	<div class="mh-preheader">
    	<div class="mh-container mh-container-inner mh-row clearfix">
							<div class="mh-header-bar-content mh-header-bar-top-left mh-col-2-3 clearfix">
											<nav class="mh-navigation mh-header-nav mh-header-nav-top clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
							<div class="menu-header-menu-container"><ul id="menu-header-menu" class="menu"><li id="menu-item-6026" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6026"><a href="http://jobmatchnc.com">Jobs</a></li>
<li id="menu-item-7216" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7216"><a href="https://mooresvillenc.circulationpro.com/scripts/WebObjects.exe/MooresvilleNCLumbertonSS">Subscribe</a></li>
<li id="menu-item-6025" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6025"><a href="https://ansonrecord.com/classifieds">Classifieds</a></li>
<li id="menu-item-6076" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6076"><a href="https://ansonrecord.com/sign-up-for-notices">Get Alerts</a></li>
<li id="menu-item-6036" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6036"><a href="https://itunes.apple.com/us/app/the-anson-record/id1042351690?mt=8">iPhone/iPad App</a></li>
<li id="menu-item-6037" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6037"><a href="https://play.google.com/store/apps/details?id=com.vervewireless.droid.ansonrecord">Android App</a></li>
</ul></div>						</nav>
									</div>
										<div class="mh-header-bar-content mh-header-bar-top-right mh-col-1-3 clearfix">
											<nav class="mh-social-icons mh-social-nav mh-social-nav-top clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
							<div class="menu-social-container"><ul id="menu-social" class="menu"><li id="menu-item-6034" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6034"><a href="http://www.facebook.com/pages/Anson-Record/180849995282535?ref=ts"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Facebook</span></a></li>
<li id="menu-item-6035" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6035"><a href="http://twitter.com/TheAnsonRecord"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Twitter</span></a></li>
</ul></div>						</nav>
									</div>
					</div>
	</div>
<header class="mh-header" itemscope="itemscope" itemtype="http://schema.org/WPHeader">
	<div class="mh-container mh-container-inner clearfix">
		<div class="mh-custom-header clearfix">
<div class="mh-header-columns mh-row clearfix">
<div class="mh-col-1-3 mh-site-identity">
<div class="mh-site-logo" role="banner" itemscope="itemscope" itemtype="http://schema.org/Brand">
<a href="https://ansonrecord.com/" class="custom-logo-link" rel="home"><img width="300" height="86" src="https://s24519.pcdn.co/wp-content/uploads/2018/02/cropped-ansonlogo-2.png" class="custom-logo" alt="Anson Record" /></a></div>
</div>
<aside class="mh-col-2-3 mh-header-widget-2">
<div id="custom_html-4" class="widget_text mh-widget mh-header-2 widget_custom_html"><div class="textwidget custom-html-widget"><ins data-revive-zoneid="10" data-revive-id="536abf87d1f56ff662219619e5b36223"></ins>
			<script async src="//championads.midtc.com/www/delivery/asyncjs.php"></script></div></div></aside>
</div>
</div>
	</div>
	<div class="mh-main-nav-wrap">
		<nav class="mh-navigation mh-main-nav mh-container mh-container-inner clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
			<div id="mega-menu-wrap-mh_main_nav" class="mega-menu-wrap"><div class="mega-menu-toggle"><div class="mega-toggle-blocks-left"></div><div class="mega-toggle-blocks-center"></div><div class="mega-toggle-blocks-right"><div class='mega-toggle-block mega-menu-toggle-block mega-toggle-block-1' id='mega-toggle-block-1' tabindex='0'><span class='mega-toggle-label' role='button' aria-expanded='false'><span class='mega-toggle-label-closed'>MENU</span><span class='mega-toggle-label-open'>MENU</span></span></div></div></div><ul id="mega-menu-mh_main_nav" class="mega-menu max-mega-menu mega-menu-horizontal mega-no-js" data-event="hover_intent" data-effect="fade_up" data-effect-speed="200" data-effect-mobile="disabled" data-effect-speed-mobile="0" data-mobile-force-width="false" data-second-click="go" data-document-click="collapse" data-vertical-behaviour="standard" data-breakpoint="600" data-unbind="true"><li class='mega-menu-item mega-menu-item-type-custom mega-menu-item-object-custom mega-menu-item-home mega-menu-item-has-children mega-align-bottom-left mega-menu-flyout mega-menu-item-2716' id='mega-menu-item-2716'><a class="mega-menu-link" href="https://ansonrecord.com" aria-haspopup="true" aria-expanded="false" tabindex="0">Home<span class="mega-indicator"></span></a>
<ul class="mega-sub-menu">
<li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2725' id='mega-menu-item-2725'><a class="mega-menu-link" href="https://ansonrecord.com/about-us">About Us</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2726' id='mega-menu-item-2726'><a class="mega-menu-link" href="https://ansonrecord.com/advertise">Advertise</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2727' id='mega-menu-item-2727'><a class="mega-menu-link" href="https://ansonrecord.com/contact-us">Contact Us</a></li><li class='mega-menu-item mega-menu-item-type-custom mega-menu-item-object-custom mega-menu-item-2731' id='mega-menu-item-2731'><a class="mega-menu-link" href="http://www.facebook.com/pages/Anson-Record/180849995282535">Anson Record on Facebook</a></li><li class='mega-menu-item mega-menu-item-type-custom mega-menu-item-object-custom mega-menu-item-2732' id='mega-menu-item-2732'><a class="mega-menu-link" href="http://twitter.com/TheAnsonRecord">Anson Record on Twitter</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2728' id='mega-menu-item-2728'><a class="mega-menu-link" href="https://ansonrecord.com/reader-services">Reader Services</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2729' id='mega-menu-item-2729'><a class="mega-menu-link" href="https://ansonrecord.com/sign-up-for-notices">Sign Up For Notices</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2730' id='mega-menu-item-2730'><a class="mega-menu-link" href="https://ansonrecord.com/subscribe">Subscribe</a></li><li class='mega-menu-item mega-menu-item-type-custom mega-menu-item-object-custom mega-menu-item-7473' id='mega-menu-item-7473'><a class="mega-menu-link" href="https://www.championcarolinas.com/terms/">Terms of Service</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-7472' id='mega-menu-item-7472'><a class="mega-menu-link" href="https://ansonrecord.com/privacy-policy">Privacy Policy</a></li></ul>
</li><li class='mega-menu-item mega-menu-item-type-taxonomy mega-menu-item-object-category mega-menu-item-has-children mega-align-bottom-left mega-menu-flyout mega-menu-item-2717' id='mega-menu-item-2717'><a class="mega-menu-link" href="https://ansonrecord.com/category/news" aria-haspopup="true" aria-expanded="false" tabindex="0">News<span class="mega-indicator"></span></a>
<ul class="mega-sub-menu">
<li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2733' id='mega-menu-item-2733'><a class="mega-menu-link" href="https://ansonrecord.com/archives">Archives</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2734' id='mega-menu-item-2734'><a class="mega-menu-link" href="https://ansonrecord.com/circulars">Circulars</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-4253' id='mega-menu-item-4253'><a class="mega-menu-link" href="https://ansonrecord.com/president">President Trump</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2736' id='mega-menu-item-2736'><a class="mega-menu-link" href="https://ansonrecord.com/online-community">Online Community</a></li><li class='mega-menu-item mega-menu-item-type-taxonomy mega-menu-item-object-category mega-menu-item-6080' id='mega-menu-item-6080'><a class="mega-menu-link" href="https://ansonrecord.com/category/special-sections">Special Sections</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2738' id='mega-menu-item-2738'><a class="mega-menu-link" href="https://ansonrecord.com/formnewstip">Submit News Tip</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2739' id='mega-menu-item-2739'><a class="mega-menu-link" href="https://ansonrecord.com/onlineforms">Online Forms</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2740' id='mega-menu-item-2740'><a class="mega-menu-link" href="https://ansonrecord.com/subscribe">Subscribe</a></li></ul>
</li><li class='mega-menu-item mega-menu-item-type-taxonomy mega-menu-item-object-category mega-menu-item-has-children mega-align-bottom-left mega-menu-flyout mega-menu-item-2718' id='mega-menu-item-2718'><a class="mega-menu-link" href="https://ansonrecord.com/category/sports" aria-haspopup="true" aria-expanded="false" tabindex="0">Sports<span class="mega-indicator"></span></a>
<ul class="mega-sub-menu">
<li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2741' id='mega-menu-item-2741'><a class="mega-menu-link" href="https://ansonrecord.com/formscores">Submit Scores</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2742' id='mega-menu-item-2742'><a class="mega-menu-link" href="https://ansonrecord.com/formsportsnews">Submit Sports News</a></li><li class='mega-menu-item mega-menu-item-type-custom mega-menu-item-object-custom mega-menu-item-3480' id='mega-menu-item-3480'><a class="mega-menu-link" href="http://pro32.ap.org/ansonrecord">Pro32</a></li><li class='mega-menu-item mega-menu-item-type-custom mega-menu-item-object-custom mega-menu-item-3481' id='mega-menu-item-3481'><a class="mega-menu-link" href="http://wintergames.ap.org/ansonrecord">AP Olympics Coverage</a></li><li class='mega-menu-item mega-menu-item-type-custom mega-menu-item-object-custom mega-menu-item-3482' id='mega-menu-item-3482'><a class="mega-menu-link" href="http://racing.ap.org/ansonrecord">Auto Racing</a></li><li class='mega-menu-item mega-menu-item-type-custom mega-menu-item-object-custom mega-menu-item-3483' id='mega-menu-item-3483'><a class="mega-menu-link" href="http://collegebasketball.ap.org/ansonrecord">College Basketball</a></li><li class='mega-menu-item mega-menu-item-type-custom mega-menu-item-object-custom mega-menu-item-3484' id='mega-menu-item-3484'><a class="mega-menu-link" href="http://collegefootball.ap.org/ansonrecord">College Football</a></li></ul>
</li><li class='mega-menu-item mega-menu-item-type-custom mega-menu-item-object-custom mega-align-bottom-left mega-menu-flyout mega-menu-item-2722' id='mega-menu-item-2722'><a class="mega-menu-link" href="http://www.legacy.com/obituaries/ansonrecord" tabindex="0">Obituaries</a></li><li class='mega-menu-item mega-menu-item-type-taxonomy mega-menu-item-object-category mega-current-post-ancestor mega-menu-item-has-children mega-align-bottom-left mega-menu-flyout mega-menu-item-2719' id='mega-menu-item-2719'><a class="mega-menu-link" href="https://ansonrecord.com/category/opinion" aria-haspopup="true" aria-expanded="false" tabindex="0">Opinion<span class="mega-indicator"></span></a>
<ul class="mega-sub-menu">
<li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2743' id='mega-menu-item-2743'><a class="mega-menu-link" href="https://ansonrecord.com/formeditor">Submit Letter To The Editor</a></li></ul>
</li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-align-bottom-left mega-menu-flyout mega-menu-item-2723' id='mega-menu-item-2723'><a class="mega-menu-link" href="https://ansonrecord.com/calendar" tabindex="0">Calendar</a></li><li class='mega-menu-item mega-menu-item-type-taxonomy mega-menu-item-object-category mega-menu-item-has-children mega-align-bottom-left mega-menu-flyout mega-menu-item-2720' id='mega-menu-item-2720'><a class="mega-menu-link" href="https://ansonrecord.com/category/features" aria-haspopup="true" aria-expanded="false" tabindex="0">Features<span class="mega-indicator"></span></a>
<ul class="mega-sub-menu">
<li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-3330' id='mega-menu-item-3330'><a class="mega-menu-link" href="https://ansonrecord.com/games">Games & Puzzles</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2744' id='mega-menu-item-2744'><a class="mega-menu-link" href="https://ansonrecord.com/comics">Comics</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2745' id='mega-menu-item-2745'><a class="mega-menu-link" href="https://ansonrecord.com/contests">Contests</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2746' id='mega-menu-item-2746'><a class="mega-menu-link" href="https://ansonrecord.com/horoscopes">Horoscopes</a></li><li class='mega-menu-item mega-menu-item-type-taxonomy mega-menu-item-object-category mega-menu-item-6079' id='mega-menu-item-6079'><a class="mega-menu-link" href="https://ansonrecord.com/category/special-sections">Special Sections</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2749' id='mega-menu-item-2749'><a class="mega-menu-link" href="https://ansonrecord.com/formanniversary">Submit Anniversary</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2751' id='mega-menu-item-2751'><a class="mega-menu-link" href="https://ansonrecord.com/formbirthday">Submit Birthday</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2752' id='mega-menu-item-2752'><a class="mega-menu-link" href="https://ansonrecord.com/formengagement">Submit Engagement</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2753' id='mega-menu-item-2753'><a class="mega-menu-link" href="https://ansonrecord.com/formwedding">Submit Wedding</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-6266' id='mega-menu-item-6266'><a class="mega-menu-link" href="https://ansonrecord.com/submit-military-promotion-graduation">Submit Military Promotion/Graduation</a></li></ul>
</li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-has-children mega-align-bottom-left mega-menu-flyout mega-menu-item-2724' id='mega-menu-item-2724'><a class="mega-menu-link" href="https://ansonrecord.com/entertainment" aria-haspopup="true" aria-expanded="false" tabindex="0">Entertainment<span class="mega-indicator"></span></a>
<ul class="mega-sub-menu">
<li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2759' id='mega-menu-item-2759'><a class="mega-menu-link" href="https://ansonrecord.com/tvlistings">TV Listings</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2760' id='mega-menu-item-2760'><a class="mega-menu-link" href="https://ansonrecord.com/tvnews">TV News</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2762' id='mega-menu-item-2762'><a class="mega-menu-link" href="https://ansonrecord.com/tvsports">TV Sports</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2763' id='mega-menu-item-2763'><a class="mega-menu-link" href="https://ansonrecord.com/tvtalk">TV Talk</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2758' id='mega-menu-item-2758'><a class="mega-menu-link" href="https://ansonrecord.com/tvbestbets">TV Best Bets</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2754' id='mega-menu-item-2754'><a class="mega-menu-link" href="https://ansonrecord.com/games">Games</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2755' id='mega-menu-item-2755'><a class="mega-menu-link" href="https://ansonrecord.com/tvmovies">Movies</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2756' id='mega-menu-item-2756'><a class="mega-menu-link" href="https://ansonrecord.com/tvqa">Q &#038; A</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2757' id='mega-menu-item-2757'><a class="mega-menu-link" href="https://ansonrecord.com/tvsoaps">Soaps</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2764' id='mega-menu-item-2764'><a class="mega-menu-link" href="https://ansonrecord.com/tvvideo">TV Video</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2761' id='mega-menu-item-2761'><a class="mega-menu-link" href="https://ansonrecord.com/tvsearch">TV Search</a></li></ul>
</li><li class='mega-menu-item mega-menu-item-type-custom mega-menu-item-object-custom mega-menu-item-has-children mega-align-bottom-left mega-menu-flyout mega-menu-item-5866' id='mega-menu-item-5866'><a class="mega-menu-link" href="http://local.ansonrecord.com" aria-haspopup="true" aria-expanded="false" tabindex="0">Businesses<span class="mega-indicator"></span></a>
<ul class="mega-sub-menu">
<li class='mega-menu-item mega-menu-item-type-custom mega-menu-item-object-custom mega-menu-item-2721' id='mega-menu-item-2721'><a class="mega-menu-link" href="http://local.ansonrecord.com">Business Directory</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-5857' id='mega-menu-item-5857'><a class="mega-menu-link" href="https://ansonrecord.com/advertise">Advertise With Us</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-5855' id='mega-menu-item-5855'><a class="mega-menu-link" href="https://ansonrecord.com/advertiser-pay">Advertiser Pay</a></li></ul>
</li></ul></div>		</nav>
	</div>
	</header>
	<div class="mh-subheader">
		<div class="mh-container mh-container-inner mh-row clearfix">
							<div class="mh-header-bar-content mh-header-bar-bottom-left mh-col-2-3 clearfix">
											<div class="mh-header-ticker mh-header-ticker-bottom">
							<div class="mh-ticker-bottom">
			<div class="mh-ticker-title mh-ticker-title-bottom">
			News Ticker<i class="fa fa-chevron-right"></i>		</div>
		<div class="mh-ticker-content mh-ticker-content-bottom">
		<ul id="mh-ticker-loop-bottom">				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://ansonrecord.com/news/9632/new-rules" title="&#8212; NEW RULES &#8212;">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ March 17, 2020 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							&#8212; NEW RULES &#8212;						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																News							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://ansonrecord.com/uncategorized/9631/faith-calendar-20" title="Faith Calendar">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ March 17, 2020 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							Faith Calendar						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																Uncategorized							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://ansonrecord.com/news/9630/9630" title="">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ March 17, 2020 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
													</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																News							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://ansonrecord.com/news/9629/anson-county-does-its-best-to-prepare" title="Anson County does its best to prepare">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ March 17, 2020 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							Anson County does its best to prepare						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																News							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://ansonrecord.com/news/9627/letter-from-the-town-manager" title="Letter from the Town Manager">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ March 17, 2020 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							Letter from the Town Manager						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																News							</span>
											</a>
				</li>		</ul>
	</div>
</div>						</div>
									</div>
								</div>
	</div>
<div class="mh-wrapper clearfix">
	<div class="mh-main clearfix">
		<div id="main-content" class="mh-content" role="main" itemprop="mainContentOfPage"><nav class="mh-breadcrumb"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="https://ansonrecord.com" itemprop="url"><span itemprop="title">Home</span></a></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span><a href="https://ansonrecord.com/category/opinion">Opinion</a><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="https://ansonrecord.com/category/opinion/letters" itemprop="url"><span itemprop="title">Letters</span></a></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span>Drawing a parallel between &#8216;Sound of Music&#8217; and impeachment hearing</nav>
<style>
.neFileBlock{
	display:none;
}
</style>
<article id="post-8984" class="post-8984 post type-post status-publish format-standard hentry category-letters">
	<header class="entry-header clearfix"><h1 class="entry-title">Drawing a parallel between &#8216;Sound of Music&#8217; and impeachment hearing</h1><div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://ansonrecord.com/date/2019/12">December 18, 2019</a></span>
<span class="entry-meta-author author vcard"><i class="fa fa-user"></i><a class="fn" href="https://ansonrecord.com/author/englewoodindependent">Anson Record</a></span>
<span class="entry-meta-categories"><i class="fa fa-folder-open-o"></i><a href="https://ansonrecord.com/category/opinion/letters" rel="category tag">Letters</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing#respond" class="mh-comment-count-link" ><span class="dsq-postid" data-dsqidentifier="8984 https://ansonrecord.com/?p=8984">0</span></a></span>
</div>
			</header>
		<div class="entry-content clearfix"><div class="mh-social-top">
<div class="mh-share-buttons clearfix">
	<a class="mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fansonrecord.com%2Fopinion%2Fletters%2F8984%2Fdrawing-a-parallel-between-sound-of-music-and-impeachment-hearing&t=Drawing+a+parallel+between+%E2%80%98Sound+of+Music%E2%80%99+and+impeachment+hearing', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
		<span class="mh-share-button"><i class="fa fa-facebook"></i></span>
	</a>
	<a class="mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=Drawing+a+parallel+between+%E2%80%98Sound+of+Music%E2%80%99+and+impeachment+hearing:&url=https%3A%2F%2Fansonrecord.com%2Fopinion%2Fletters%2F8984%2Fdrawing-a-parallel-between-sound-of-music-and-impeachment-hearing', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
		<span class="mh-share-button"><i class="fa fa-twitter"></i></span>
	</a>
	<a class="mh-pinterest" href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fansonrecord.com%2Fopinion%2Fletters%2F8984%2Fdrawing-a-parallel-between-sound-of-music-and-impeachment-hearing&media=&description=Drawing+a+parallel+between+%E2%80%98Sound+of+Music%E2%80%99+and+impeachment+hearing', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
		<span class="mh-share-button"><i class="fa fa-pinterest"></i></span>
	</a>
	<a class="mh-googleplus" href="#" onclick="window.open('https://plusone.google.com/_/+1/confirm?hl=en-US&url=https%3A%2F%2Fansonrecord.com%2Fopinion%2Fletters%2F8984%2Fdrawing-a-parallel-between-sound-of-music-and-impeachment-hearing', 'googleShare', 'width=626,height=436'); return false;" title="Share on Google+" target="_blank">
		<span class="mh-share-button"><i class="fa fa-google-plus"></i></span>
	</a>
	<a class="mh-email" href="mailto:?subject=Drawing%20a%20parallel%20between%20%E2%80%98Sound%20of%20Music%E2%80%99%20and%20impeachment%20hearing&amp;body=https%3A%2F%2Fansonrecord.com%2Fopinion%2Fletters%2F8984%2Fdrawing-a-parallel-between-sound-of-music-and-impeachment-hearing" title="Send this article to a friend" target="_blank">
		<span class="mh-share-button"><i class="fa fa-envelope-o"></i></span>
	</a>
</div></div>
																		
																																<p>I watched the impeachment hearings. I heard the indisputable testimony of patriotic professionals whose integrity had never been questioned, and who had never been insultingly criticized until they told the truth about political corruption. I was shocked at the rancor of those who could not refute their truthful message, so angrily attacked the messengers.</p>
<p>The following Sunday night, I watched &#8220;The Sound of Music&#8221; on ABC, the story of a naval commander who dearly loved his nation, appreciated its form of government, and resisted his fellow citizens&#8217; yield to takeover by a dictator.</p>
<p>Although the motion picture was filmed for entertainment, it was based on an actual historical event, and the anger in the voices of the actors who so effectively portrayed the traitors willing to turn their nation over to a dictator was sadly reminiscent of the anger I heard in the voices of those who attacked the truthful witnesses in the impeachment hearings, when they could not refute their testimony.</p>
<p><strong>Robert C. Currie Jr.</strong></p>
<p>Laurinburg</p>
		
		<div class="mh-social-bottom">
<div class="mh-share-buttons clearfix">
	<a class="mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fansonrecord.com%2Fopinion%2Fletters%2F8984%2Fdrawing-a-parallel-between-sound-of-music-and-impeachment-hearing&t=Drawing+a+parallel+between+%E2%80%98Sound+of+Music%E2%80%99+and+impeachment+hearing', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
		<span class="mh-share-button"><i class="fa fa-facebook"></i></span>
	</a>
	<a class="mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=Drawing+a+parallel+between+%E2%80%98Sound+of+Music%E2%80%99+and+impeachment+hearing:&url=https%3A%2F%2Fansonrecord.com%2Fopinion%2Fletters%2F8984%2Fdrawing-a-parallel-between-sound-of-music-and-impeachment-hearing', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
		<span class="mh-share-button"><i class="fa fa-twitter"></i></span>
	</a>
	<a class="mh-pinterest" href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fansonrecord.com%2Fopinion%2Fletters%2F8984%2Fdrawing-a-parallel-between-sound-of-music-and-impeachment-hearing&media=&description=Drawing+a+parallel+between+%E2%80%98Sound+of+Music%E2%80%99+and+impeachment+hearing', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
		<span class="mh-share-button"><i class="fa fa-pinterest"></i></span>
	</a>
	<a class="mh-googleplus" href="#" onclick="window.open('https://plusone.google.com/_/+1/confirm?hl=en-US&url=https%3A%2F%2Fansonrecord.com%2Fopinion%2Fletters%2F8984%2Fdrawing-a-parallel-between-sound-of-music-and-impeachment-hearing', 'googleShare', 'width=626,height=436'); return false;" title="Share on Google+" target="_blank">
		<span class="mh-share-button"><i class="fa fa-google-plus"></i></span>
	</a>
	<a class="mh-email" href="mailto:?subject=Drawing%20a%20parallel%20between%20%E2%80%98Sound%20of%20Music%E2%80%99%20and%20impeachment%20hearing&amp;body=https%3A%2F%2Fansonrecord.com%2Fopinion%2Fletters%2F8984%2Fdrawing-a-parallel-between-sound-of-music-and-impeachment-hearing" title="Send this article to a friend" target="_blank">
		<span class="mh-share-button"><i class="fa fa-envelope-o"></i></span>
	</a>
</div></div>
			</div></article><nav class="mh-post-nav mh-row clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<div class="mh-col-1-2 mh-post-nav-item mh-post-nav-prev">
<a href="https://ansonrecord.com/news/8983/ncdot-announces-grants-for-university-research-projects-to-improve-transportation" rel="prev"><span>Previous</span><p>NCDOT announces grants for university research projects to improve transportation</p></a></div>
<div class="mh-col-1-2 mh-post-nav-item mh-post-nav-next">
<a href="https://ansonrecord.com/news/8990/hillbilly-santa-tractors-into-town" rel="next"><img width="80" height="60" src="https://s24519.pcdn.co/wp-content/uploads/2019/12/web1_IMGP3959-2--80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="" srcset="https://s24519.pcdn.co/wp-content/uploads/2019/12/web1_IMGP3959-2--80x60.jpg 80w, https://s24519.pcdn.co/wp-content/uploads/2019/12/web1_IMGP3959-2--326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /><span>Next</span><p>&#8216;Hillbilly Santa&#8217; tractors into town</p></a></div>
</nav>
				<ins class="adbladeads" data-cid="35553-1462681351" data-host="web.adblade.com" data-tag-type="4" data-subid="ansonrecord.com" data-protocol="https" style="display:none"></ins>
				<script async src="https://web.adblade.com/js/ads/async/show.js" type="text/javascript"></script>
				<a id="comments"></a>
				
<div id="disqus_thread"></div>
 <style type="text/css">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</style><div id="ajax-load-more" class="ajax-load-more-wrap infinite ring"  data-alm-id="" data-canonical-url="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing" data-slug="drawing-a-parallel-between-sound-of-music-and-impeachment-hearing" data-post-id="8984"  data-localized="ajax_load_more_vars"><ul aria-live="polite" aria-atomic="true" class="alm-listing alm-ajax" data-seo="true" data-seo-start-page="1" data-seo-scroll="true" data-seo-scrolltop="30" data-seo-controls="1" data-seo-permalink="pretty" data-seo-pageview="true" data-container-type="ul" data-repeater="template_1" data-post-type="post" data-category="Letters" data-order="DESC" data-orderby="date" data-offset="1" data-posts-per-page="12" data-scroll="true" data-scroll-distance="100" data-max-pages="0" data-pause-override="false" data-pause="false" data-button-label="Next Article" data-transition="none"></ul><noscript><ul class="alm-listing alm-noscript"><div class="alm-reveal"><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://ansonrecord.com/opinion/letters/8946/new-roof-coming-just-in-time-for-christmas" title="New roof coming just in time for Christmas" style="color:black">New roof coming just in time for Christmas</a></h1>
   <p class="entry-meta">December 16, 2019</p>
   <p>The agency that makes loving everyone its business, is being loved on by many with a much-needed new roof just in time for Christmas.</p>
<p>With much anticipation, Church Community Services of Scotland County has awarded the contract to CBA Roofing of Monroe.</p>
<p>Due to the generosity of the following individuals and agencies, the roof is paid for: Pee Dee Electric; Cape Fear Realtors and Scotland County Board of Realtors; Mr. Lonnie Humphreys; Central United Methodist Church; Emerson and Dinah Veler; Frederick Ludtke; Trinity Presbyterian Church; Scotland Motors; Mr. Kenneth Etheridge; Floyd Farms; First United Methodist Church; Mr. Edward Johnston, Jr.; Bobby and Patsy Whitehead; Nic&#8217;s Pik Kwik; Bright Hopewell Missionary Baptist Church; Koinonia Class of First Baptist Church; Mr. Charles Todd; Michael and Diane Vinson; Jane Tornow; First Bank; and others.</p>
<p>With the roof completed, the agency will now begin work this next year on repairing the damaged ceiling and walls. If you, or your organization is interested in adopting a room as a project, please contact the agency at 910-276-8330, e-mail scotlandccs@gmail.com or stop by the office located directly across from the Laurinburg post office at 108 S. Gill St. in Laurinburg. Their hours of operation are Monday through Friday, 8:30 a.m. to 12:30 p.m.</p>
<p><strong>Robert Macy</strong></p>
<p>Executive director</p>
<p>Church Community Services of Scotland County, Inc.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://ansonrecord.com/opinion/letters/8812/heres-a-simple-solution-to-the-sex-trafficking-problem" title="Here&#8217;s a simple solution to the sex trafficking problem &#8230;" style="color:black">Here&#8217;s a simple solution to the sex trafficking problem &#8230;</a></h1>
   <p class="entry-meta">November 20, 2019</p>
   <p>I read news of rampant sex trafficking regularly, and hear and see the same in electronic media almost daily. I was astonished at the number of registered sex offenders parents were warned to avoid when escorting their children while trick or treating on Halloween.</p>
<p>There is a simple solution to the sex trafficking problem if America will only implement it. Yes, sex traffickers are criminals, but so are their customers who exploit sex trafficking victims. When sex traffickers are arrested, arrest, prosecute and most of all publicly expose the customers, whose sexual exploitation of the victims prove the trafficker is a sex trafficker.</p>
<p>Make the arrest of every sex trafficking customer the pictured, front-page head-line of every newspaper, and the top-story of every TV and radio news broadcast. Could sex-trafficking exist without customers?</p>
<p>Would exploiters of sex trafficking victims, especially sexually exploited children, take the risk of being so publicly exposed? Could their embarrassed families cover their crimes up?</p>
<p>What do you think?</p>
<p><strong>Robert C Curie Jr.</strong></p>
<p>Laurinburg</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://ansonrecord.com/opinion/letters/8483/a-welcome-to-the-laurinburg-exchanges-new-regional-publisher" title="A welcome to The Laurinburg Exchange&#8217;s new regional publisher" style="color:black">A welcome to The Laurinburg Exchange&#8217;s new regional publisher</a></h1>
   <p class="entry-meta">September 30, 2019</p>
   <p>Brian Bloom is now the regional publisher for The Laurinburg Exchange, the Rockingham and the Anson newspapers. I had planned to welcome him in a letter to the editor, but then had a chance encounter with him in The Exchange office this week as he was leaving there.</p>
<p>I did welcome him to our community and shook his hand. He thanked me and asked who I was. I gave him my name and said that I was a &#8220;local loony and occasional writer of letters.&#8221; He took that in stride, chuckled and said something along the line of the value of loonies in every community. He also said to use his first name.</p>
<p>I did not get a chance to tell him that he and I had some shared experience earlier in our lives. There was an Intertype machine in the newspaper printing area of Brian&#8217;s family&#8217;s newspaper business for their town. There was a Linotype machine in the print shop of my father&#8217;s printing and office supply business in the late 1960s and early 1970s. Both machines created pieces of lead type that were used on the printing presses. Like Brian, part of my job at one time was to melt down the used lead type, and create the &#8220;pigs&#8221; that were then reused to feed the type-creating machines.</p>
<p>I also did not get a chance (as Brian is a busy man these days) to give kudos to our newspaper editor and staff. On that day, Cody in the office was very helpful to and patient with me as I became a subscriber once again. I do appreciate our local newspaper, Curt Vincent and all the staff. I am &#8220;old school&#8221; &#8230; still like to hold the paper in my hands rather than view it online.</p>
<p><strong>Stephen Dickens</strong></p>
<p>Laurinburg</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://ansonrecord.com/opinion/letters/8039/theater-production-is-well-worth-taking-time-to-see" title="Theater production is well worth taking time to see" style="color:black">Theater production is well worth taking time to see</a></h1>
   <p class="entry-meta">July 15, 2019</p>
   <p>Pn Saturday, July 13, my wife Jacque and I were privileged to enjoy the ENCORE Theatre production of &#8220;Over the River and Through the Woods.&#8221; I write this both to thank the theater folk and to encourage your readers to make an effort to get to this production.</p>
<p>The play itself is a well-written and sensitive piece of Americana, full of both humor and pathos. At the same time, the performers do a wonderful job of capturing the conflicts of the plot and the differing personalities of the characters. Gary Gallman is to be congratulated for his direction, and kudos extended to Fritz and Jamie Barnes, Bob Dyer, Brenda Gilbert, Allen Johnson, and Ruth Ann Harris for their performances.</p>
<p>Laurinburg is indeed fortunate to have such opportunities available. I write to encourage everyone to take advantage of this one.</p>
<p>Sincerely yours,</p>
<p><strong>Mac Doubles</strong></p>
<p>Laurinburg</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://ansonrecord.com/opinion/letters/7924/america-is-at-the-point-of-no-return" title="America is at the point of no return" style="color:black">America is at the point of no return</a></h1>
   <p class="entry-meta">June 25, 2019</p>
   <p>It is sad to say, but on the 243rd Anniversary of the birth of this Great Nation, America has (possibly) reached the Point-Of-No-Return.</p>
<p>Added the word possibly, because, there is still a glimpse of true active believers left somewhere. And we, of course, know that all things are possible to God the creator of all.</p>
<p>But perhaps, like the Prophet Jonah, who wanted the great wicked city of Nineveh destroyed, we are reluctant to inform America of the coming destruction. We know of such destruction because we read the book, the Word of God, the Holy Bible.</p>
<p>God directed Jonah to go to Nineveh and warn that Idol worshiping city to repent, or He would destroy that city after forty days. Jonah fled from God instead. God finally got his attention by forcing Jonah to live inside a big fish for three days.</p>
<p>That terrible experience prompted Jonah to complete his assignment. So he rushed to Nineveh, and he went throughout the city announcing God&#8217;s warning. After that, not expecting that sinful city to repent, he went to a high place outside the city to observe the destruction. But the whole city repented and G od gave that city 200 more years of life before it was destroyed.</p>
<p>The Holy Bible contains many other instances where Mankind became so wicked that finally God had to punished such nations, or destroyed them. Including His beloved nation of Israel.</p>
<p>America has gone from being a God loving nation from it&#8217;s beginning, to a God hating nation in many respects. Many Americans now not only tolerate what God calls abomination, but they publicly support and considers&#8217; them as rights.</p>
<p>While America is incurring the wrath of God, because of his love, He is sending warnings in many different ways. But eventually, as prophesied in the Word of God, the day will come when Jesus will start breaking each seal on the Book, and with each seal broken bringing calamity upon Man on Earth, and on God&#8217;s universe.</p>
<p>Will American repent?</p>
<p><strong>Manuel Ybarra Jr.</strong></p>
<p>Coalgate, Oklahoma</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://ansonrecord.com/opinion/letters/7889/hazard-lights-dont-make-a-your-car-an-emergency-vehicle" title="Hazard lights don&#8217;t make a your car an emergency vehicle" style="color:black">Hazard lights don&#8217;t make a your car an emergency vehicle</a></h1>
   <p class="entry-meta">June 18, 2019</p>
   <p>On Sunday, coming home from church, I turned off Atkinson Street, turned left onto Vance Street and I got ready to go &#8212; then a car ran the red light with his flashers on. It was not a policeman or an emergency vehicle.</p>
<p>My point is this: A driver thinks because he has his flashers on, he can drive like a policeman and use his car for emergencies.</p>
<p>I have witnessed this for years.</p>
<p>It&#8217;s against the law to use your hazard lights while driving.</p>
<p>Be careful and safe.</p>
<p><strong>Jerry Campbell</strong></p>
<p>Laurinburg</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://ansonrecord.com/opinion/letters/7870/close-the-medicaid-gap-to-help-our-veterans" title="Close the Medicaid gap to help our veterans" style="color:black">Close the Medicaid gap to help our veterans</a></h1>
   <p class="entry-meta">June 17, 2019</p>
   <p>As a pastoral counselor and mental health provider, I have seen how the unaffordability of health coverage creates barriers for too many of my parishioners and patients, blocking them from getting the physical and mental health care they need. Without health coverage, illnesses are ignored and treatment is delayed until the person is so sick they end up in the emergency room &#8212; or even worse, the morgue.</p>
<p>As someone who proudly served our country, I have been particularly distressed to see veterans and their families without health coverage. There are 30,000 uninsured veterans, 12,000 who fall into the Medicaid &#8220;coverage gap,&#8221; and 23,000 of their family members who also don&#8217;t have access to health insurance in North Carolina. People in the &#8220;coverage gap&#8221; are ineligible or earn too much income for Medicaid coverage, but too little to get financial help for online marketplace plans.</p>
<p>Not all veterans are eligible for VA health care, and many come back home with complex mental health issues and inadequate means to address them. Without health coverage, sometimes there is no way to help them. This has contributed to the continuing epidemic of suicides amongst our veteran population.</p>
<p>We can support our veterans by closing the Medicaid coverage gap, and making sure they can access the mental health services they need to reduce these horrific suicide rates. Help for mental health issues should neither be stigmatizing or difficult to access, but instead encouraged and made accessible to those who need it most.</p>
<p>Of course, not just veterans are suffering because they have fallen into the coverage gap. Too many of our brothers and sisters lack access to preventive care and treatment, and have to worry about how they will pay their medical bills if they get sick or have an accident.</p>
<p>We must also do right by them.</p>
<p>This is the year. This is the time. We must do more than thank our veterans for their service. They and their families have made tremendous sacrifices. They have kept their word. Let us do our part and keep ours.</p>
<p><strong>Orlando Dowdy</strong></p>
<p>Pastoral counselor</p>
<p>Durham</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://ansonrecord.com/opinion/letters/7824/epicenters-miscues-on-traffic-were-dangerous" title="Epicenter&#8217;s miscues on traffic were dangerous" style="color:black">Epicenter&#8217;s miscues on traffic were dangerous</a></h1>
   <p class="entry-meta">June 10, 2019</p>
   <p>I am writing because I have no idea who else to write (complain) to. I traveled from Roanoke, Virginia with my wife to Richmond County to attend the Epicenter Festival.</p>
<p>I would like to first say that every person that I met while attending the music festival were most hospitable and gracious. The towns amazing. I am really unsure what has changed since I came down there in 2012 for the Carolina Rebellion. The traffic situation was a joke and the fact that &#8220;Danny Wimmer Presents&#8221; was able to get a music festival OK&#8217;d with the fire department, police, and zoning is concerning.</p>
<p>I am a registered nurse by profession and seeing the traffic and inability of emergency vehicles to get anywhere in the parking lot if needed was outrageous. I moved less than a foot in two hours while trying to exit after getting a mass text from the Epicenter App. I walked up to the entrance of the parking and found one employee attempting to direct traffic. I use this term loosely, as he was doing a horrendous job of it. Where were the people who were hired to perform these tasks? As I made my way to the state troopers directing traffic on US 1, I encountered people who were passed out at the wheel while waiting to exit.</p>
<p>I have attended many concerts and other large venue activities and this by far was the worst and most dangerous example of &#8220;what not to do &#8230;&#8221; To wrap this up, I would like to reiterate that from the state troopers and Sheriff&#8217;s deputies to all the locals who put up with the large influx of people to their towns, everyone was great. I would love to come back down there for a getaway, but I am afraid that it will not be for the next Epicenter Festival.</p>
<p><strong>Michael Lewis</strong></p>
<p>Roanoke, Virginia</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://ansonrecord.com/opinion/letters/6630/letter-president-trump-continues-to-be-a-disappointment" title="LETTER: President Trump continues to be a disappointment" style="color:black">LETTER: President Trump continues to be a disappointment</a></h1>

            <a href="https://ansonrecord.com/opinion/letters/6630/letter-president-trump-continues-to-be-a-disappointment" title="LETTER: President Trump continues to be a disappointment">
			                           <img src="https://s24519.pcdn.co/wp-content/uploads/2018/07/web1_letter_web.jpg" alt="LETTER: President Trump continues to be a disappointment">
            </a>
   <p class="entry-meta">July 10, 2018</p>
   <p>I have really, really underestimated the current President of the United States of America. Just when I thought he could not go any lower, he did.</p>
<p>Trump went down to a new low by showing nothing but disdain and absolute disregard for people who do not look like him or who do not have what he has. That is why I believe it was so easy for him to separate young, frightened immigrant children from their grieving parents and to send them to minimalist camps all over America &#8230; he does not care.</p>
<p>Yes, I have heard him say many times before that the people who illegally cross our borders are nothing more than rapists, murderers and thugs, but I beg to differ. The rapists, murderers and thugs are already over here and so are the terrorists, thieves, gangs and bullies. The people who are corrupt and who are only concerned with wealth for themselves are here, too, and have been for decades. A lot of them are disguised as politicians who took oaths for their respective offices to serve this country with pride, integrity, and truth &#8230; well, so much for that.</p>
<p>If I remember my history correctly (and I certainly do), many, many immigrants came to the United States of America to start new lives. The Irish, Germans, Polish, Italians, Asians, Sicilians, and others came here, hoping for better living conditions, better work, better wages &#8230; better lives in general. Most of them came legally, yet, certain undesirables came with them. Some of them came illegally and brought certain undesirables with them, as well. Consequently, African-Americans were forced and tricked to come here to be slaves and to endure years of beatings, rapes, torture, killings, inhumane conditions, and, yes, to endure the separation of their families, many of whom were never reunited. The separation (and, of course, the slavery) was absolutely wrong then and it is absolutely wrong now.</p>
<p>I believe that the immigrants crossing the borders illegally now are doing so because they are leaving very desperate situations. They have no financial means to book flights here. They do not have private jets or rich friends who can buy their way in. They are fleeing violence, hardship, poverty, and overall dire conditions. Yes, there may be some bad people included, but, guess what? There are bad people in every nationality, in every neighborhood, in every school, in every workplace, and in every family. Do the Sandy Hook shootings or Dylan Roof ring a bell?</p>
<p>You know, the Statue of Liberty, standing proudly on Ellis Island in New York, holds a torch that lights the way for immigrants coming into our country. It is emblazoned with these words: &#8220;Give us your tired, your poor, your huddled masses yearning to be free.&#8221; It symbolizes to foreigners that America welcomes the poor, the suffering, and the hopeless.</p>
<p>We have a charge from Almighty God to take care of the poor, the needy, the widows, and the children. Many immigrants came from all over this world just seeking a chance. They have worked hard, usually on jobs that no one else wants. They have built businesses, homes, careers, neighborhoods, colleges, churches and have contributed immensely to this country.</p>
<p>The hope of having and doing better is what really makes America great &#8230; along with its diversity of people. Remember, any of us could become destitute, or worse, at any given time &#8230; any of us. So it is imperative that our nation is led with compassion and empathy, not with an iron fist. That is not who we are &#8230; or perhaps I should say, who we were or hope to be.</p>
<p style="text-align: right;"><strong>Charlette Rhue Bennett</strong></p>
<p style="text-align: right;">Wadesboro</p>
<style>
.neFileBlock {
	margin-bottom: 20px;
}
.neFileBlock p {
	margin: 0px 0px 0px 0px;
}
.neFileBlock .neFile {
	border-bottom: 1px dotted #aaa;
	padding-bottom: 5px;
	padding-top: 10px;
}
.neFileBlock .neCaption {
	font-size: 85%;
}
</style>
<div class='neFileBlock'>
<div class="neFile"><img class="neImage" src="https://s24519.pcdn.co/wp-content/uploads/2018/07/web1_letter_web.jpg"></p>
<div class="neCaption"></div>
</div>
<div class="metaInfo"><photo0>https://ansonrecord.com/wp-content/uploads/2018/07/web1_letter_web.jpg</photo0><caption0></caption0><photoCredit0></photoCredit0></div>
</div>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://ansonrecord.com/opinion/letters/6527/was-there-a-mud-volcano-in-wadesboro" title="Was there a mud volcano in Wadesboro?" style="color:black">Was there a mud volcano in Wadesboro?</a></h1>

            <a href="https://ansonrecord.com/opinion/letters/6527/was-there-a-mud-volcano-in-wadesboro" title="Was there a mud volcano in Wadesboro?">
			                           <img src="https://s24519.pcdn.co/wp-content/uploads/2018/06/web1_guest-commentary.jpg" alt="Was there a mud volcano in Wadesboro?">
            </a>
   <p class="entry-meta">June 19, 2018</p>
   <p>The prominent hill on which Wadesboro sits is a part of the ancient Uwharrie Mountains that once extended from northern Georgia into northern Virginia. Montgomery County is somewhat considered the center of the Uwharries, although the 1,000-foot Morrow Mountain in Stanly County is the tallest remaining mountain in that chain. The Uwharries are considered among some of the oldest in the world, dating back to the Cambrian Era or around 500-million years. The mountains are volcanic in origin and could have been as tall, or taller, than the Rocky Mountains before their erosion slowly occurred over many millions of years.</p>
<p>Through Risden Hill and Steve Bailey of Wadesboro, I recently learned about the Lineham Brownstone Quarry that is located back of North Wadesboro Baptist Church between Highways 109 and old 52. Having studied geology and mineralogy and establishing somewhat science-related businesses, along with producing a documentary on the geological history of the Uwharries, I became extremely interested in this Wadesboro rock formation. Mr. Hill told me about several locations in Wadesboro where I could see specimens of this brownstone, including downtown near the D.A.R. Monument, under the foundation of his house and other locations. I also viewed a 20-inch square by 5-foot-long block of this brownstone at a home on East Morgan Street that was removed from that Lineham quarry. I eventually acquired a couple small specimens and began close examination along with making various tests and research.</p>
<p>The Peterson Rock and Mineral Field Guide states that brownstone is a sedimentary sandstone that occurs in many areas of the country and widely used in construction of foundations and stone walls. Over my career I handled many specimens of sandstone from areas all around the country and all have been light in color and consisted mostly of sand bound together with silicate or calcium. The Wadesboro brownstone consists of only a small portion of sand and originally mostly red mud.. Wadesboro is part of the Uwharrie Mountains and is an igneous (volcanic) formation and not a sedimentary formation. Because of these inconsistencies. I do not believe this brownstone should be classified as a sedimentary sandstone.</p>
<p>It is my opinion that the brownstone rock formation was created from a &#8220;mud volcano.&#8221; As an example, there are numerous mud volcanoes in Yellowstone National Park consisting of bubbling mud pots, as they are called, with mud flowing out and solidifying to form large mounds, etc. A mud volcano consists of superheated steam and gases coming up from deep within the earth that dissolve clays and some rocks while producing an outflow of accumulating bubbling mud and sometimes even a violent explosion of mud. On June 4, 2018, Guatemala&#8217;s Fuego Volcano had a gigantic explosion of mud. It coated trees with mud and engulfed houses and other buildings with rivers of brown mud killing more than 38 people.</p>
<p>The brownstone from Wadesboro has a red mud color from the presence of iron oxide. When broken apart, some surfaces show a botryoidal (lumpy) texture that occurred as it cooled and hardened. It has a surface hardness rating of around 6 on the Mohs Hardness Scale which indicates the mud was possibly, and eventually, bound together from dissolved silicates as occurred with most petrified wood.</p>
<p>It is also my opinion that the large Wadesboro deposit of extruded or exploded volcanic mud occurred during the early formation of the Uwarries, 400 to 500 million years ago, and was later covered with volcanic ash and lava perhaps to a height of a thousand feet or more. Over a period of these several hundred million years, the mountains eroded down to Wadesboro&#8217;s current elevation of around 512 feet above sea level, exposing the mudstone deposit that had solidified or, in a sense, &#8220;petrified&#8221; into the brownstone rock formation.</p>
<p><em>T.D. Burns lives in Matthews.</em></p>
<style>
.neFileBlock {
	margin-bottom: 20px;
}
.neFileBlock p {
	margin: 0px 0px 0px 0px;
}
.neFileBlock .neFile {
	border-bottom: 1px dotted #aaa;
	padding-bottom: 5px;
	padding-top: 10px;
}
.neFileBlock .neCaption {
	font-size: 85%;
}
</style>
<div class='neFileBlock'>
<div class="neFile"><img class="neImage" src="https://s24519.pcdn.co/wp-content/uploads/2018/06/web1_guest-commentary.jpg"></p>
<div class="neCaption"></div>
</div>
<div class="metaInfo"><photo0>https://ansonrecord.com/wp-content/uploads/2018/06/web1_guest-commentary.jpg</photo0><caption0></caption0><photoCredit0></photoCredit0></div>
</div>
<div class="metaInfo"><bylineMeta></p>
<p>T.D. Burns</p>
<p>Contributing columnist</p>
<p></bylineMeta></div>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://ansonrecord.com/opinion/letters/6134/in-search-of-my-roots" title="In search of my roots" style="color:black">In search of my roots</a></h1>

            <a href="https://ansonrecord.com/opinion/letters/6134/in-search-of-my-roots" title="In search of my roots">
			                           <img src="https://s24519.pcdn.co/wp-content/uploads/2018/03/web1_letter_web-1.jpg" alt="In search of my roots">
            </a>
   <p class="entry-meta">March 06, 2018</p>
   <p><strong>To the editor:</strong></p>
<p>I am in the process of finding my roots. I began with the results of my DNA. I have researched my ancestral history and discovered family cousins I never knew I had &#8212; many living next door to me and beyond &#8212;both national and international.</p>
<p>I am seeking a photo and any information about my great-great-great-grandmother, Helen Teal Willoughby (Helen Teal Dawkins.)</p>
<p>Helen was married to John Dawkins and later married another by the name of Stephen Willoughby. Helen was born in 1873 and died in 1932 and buried at Bethel Church Cemetery.</p>
<p>In addition, I am seeking information leading to the father of Vance Teal Sr. His mother was Helen Teal (mulatto). Vance Teal is buried at Madison Grove Church Cemetery along with his wife, Daisy Lee Teal. Vance was born in 1885 and died in 1950.</p>
<p>Information and or photos of Helen Teal would help me in the search of my roots.</p>
<p>Information leading to the above information can be forwarded to the following email address: Bobbyrorie123@comcast.net.</p>
<p><strong>Dr. Bobby Rorie</strong></p>
<style>
.neFileBlock {
	margin-bottom: 20px;
}
.neFileBlock p {
	margin: 0px 0px 0px 0px;
}
.neFileBlock .neFile {
	border-bottom: 1px dotted #aaa;
	padding-bottom: 5px;
	padding-top: 10px;
}
.neFileBlock .neCaption {
	font-size: 85%;
}
</style>
<div class='neFileBlock'>
<div class="neFile"><img class="neImage" src="https://s24519.pcdn.co/wp-content/uploads/2018/03/web1_letter_web-1.jpg"></p>
<div class="neCaption"></div>
</div>
<div class="metaInfo"><photo0>https://ansonrecord.com/wp-content/uploads/2018/03/web1_letter_web-1.jpg</photo0><caption0></caption0><photoCredit0></photoCredit0></div>
</div>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://ansonrecord.com/opinion/letters/5691/letter-tax-cuts-would-turbocharge-economic-growth" title="LETTER: Tax cuts would &#8216;turbocharge&#8217; economic growth" style="color:black">LETTER: Tax cuts would &#8216;turbocharge&#8217; economic growth</a></h1>

            <a href="https://ansonrecord.com/opinion/letters/5691/letter-tax-cuts-would-turbocharge-economic-growth" title="LETTER: Tax cuts would &#8216;turbocharge&#8217; economic growth">
			                           <img src="https://s24519.pcdn.co/wp-content/uploads/2017/11/web1_letter_web.jpg" alt="LETTER: Tax cuts would &amp;#8216;turbocharge&amp;#8217; economic growth">
            </a>
   <p class="entry-meta">November 14, 2017</p>
   <p><strong>To the editor:</strong></p>
<p>As the 2017 legislative calendar comes to a close, it is time for Congress to come together and seize this once-in-a-generation opportunity to pass pro-growth tax cuts. This would bring additional tax relief to North Carolina&#8217;s small businesses and hardworking taxpayers.</p>
<p>North Carolina is no stranger to the benefit of tax cuts. Our state dramatically cut taxes in 2013, and since then, we have experienced budget surpluses, a reduction in unemployment, and the creation of hundreds of thousands of new jobs.</p>
<p>But there&#8217;s only so much that can be done on the state level. Federal legislators must follow North Carolina&#8217;s lead and pass recently proposed tax cuts that would lower the top marginal small business tax rate to 25 percent, among other rate reductions.</p>
<p>This would turbocharge economic growth in the Tar Heel state and across the country.</p>
<p style="text-align: right;"><strong>Peter Cotter</strong></p>
<p style="text-align: right;">Managing Director, Burger King</p>
<p style="text-align: right;">Raleigh</p>
<style>
.neFileBlock {
	margin-bottom: 20px;
}
.neFileBlock p {
	margin: 0px 0px 0px 0px;
}
.neFileBlock .neFile {
	border-bottom: 1px dotted #aaa;
	padding-bottom: 5px;
	padding-top: 10px;
}
.neFileBlock .neCaption {
	font-size: 85%;
}
</style>
<div class='neFileBlock'>
<div class="neFile"><img class="neImage" src="https://s24519.pcdn.co/wp-content/uploads/2017/11/web1_letter_web.jpg"></p>
<div class="neCaption"></div>
</div>
<div class="metaInfo"><photo0>https://ansonrecord.com/wp-content/uploads/2017/11/web1_letter_web.jpg</photo0><caption0></caption0><photoCredit0></photoCredit0></div>
</div>
</article>

</div></div></ul><div class="alm-paging" style="opacity: 1">Pages: <span class="page"><u>1</u></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/2">2</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/3">3</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/4">4</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/5">5</a></span><span><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/5">Last Page</a></span></div></noscript><div class="alm-btn-wrap" style="visibility: hidden;"><button class="alm-load-more-btn more " rel="next">Next Article</button></div></div>		</div>
			<aside class="mh-widget-col-1 mh-sidebar" itemscope="itemscope" itemtype="http://schema.org/WPSideBar"><div id="custom_html-15" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Weather</span></h4><div class="textwidget custom-html-widget"><div style="width: 300px;"><iframe style="display: block;" src="https://cdnres.willyweather.com/widget/loadView.html?id=106673" width="300" height="228" frameborder="0" scrolling="no"></iframe><a style="height: 20px;margin: -20px 0 0 0;z-index: 1;display: block;text-indent: -9999em;position: relative" href="/weather" rel="nofollow">Weather info for Wadesboro</a></div></div></div><div id="custom_html-24" class="widget_text mh-widget widget_custom_html"><div class="textwidget custom-html-widget"><ins data-revive-zoneid="326" data-revive-id="536abf87d1f56ff662219619e5b36223"></ins>
<script async src="//championads.midtc.com/www/delivery/asyncjs.php"></script></div></div><div id="custom_html-16" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Advertisement</span></h4><div class="textwidget custom-html-widget"><ins data-revive-zoneid="6" data-revive-id="536abf87d1f56ff662219619e5b36223"></ins>
				<script async src="//championads.midtc.com/www/delivery/asyncjs.php"></script>	</div></div><div id="custom_html-22" class="widget_text mh-widget widget_custom_html"><div class="textwidget custom-html-widget"><!---<div id="circularhub_module_12283"></div><script src="//api.circularhub.com/12283/9045f19d1f155488/circularhub_module.js"></script>---></div></div><div id="custom_html-17" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Advertisement</span></h4><div class="textwidget custom-html-widget"><ins data-revive-zoneid="7" data-revive-id="536abf87d1f56ff662219619e5b36223"></ins>
				<script async src="//championads.midtc.com/www/delivery/asyncjs.php"></script></div></div><div id="custom_html-23" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">National Video</span></h4><div class="textwidget custom-html-widget"><div class="inform-embed"  data-type="VideoLauncher/Slider" data-tracking-group="93003"></div>
<script type="text/javascript">_informq.push(['embed']); vid.muted = true;</script>
<script src="https://launch.inform.com/js/embed.js"></script></div></div><div id="custom_html-20" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Advertisement</span></h4><div class="textwidget custom-html-widget"><ins data-revive-zoneid="8" data-revive-id="536abf87d1f56ff662219619e5b36223"></ins>
				<script async src="//championads.midtc.com/www/delivery/asyncjs.php"></script>	</div></div><div id="custom_html-21" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Advertisement</span></h4><div class="textwidget custom-html-widget"><ins data-revive-zoneid="9" data-revive-id="536abf87d1f56ff662219619e5b36223"></ins>
			<script async src="//championads.midtc.com/www/delivery/asyncjs.php"></script>	</div></div><div id="custom_html-27" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Editor&#8217;s Picks</span></h4><div class="textwidget custom-html-widget"><div id="ajax-load-more-2" class="ajax-load-more-wrap infinite ring" data-id="2275609599" data-alm-id="" data-canonical-url="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing" data-slug="drawing-a-parallel-between-sound-of-music-and-impeachment-hearing" data-post-id="8984"  data-localized="ajax_load_more_2275609599_vars"><div aria-live="polite" aria-atomic="true" class="alm-listing alm-ajax" data-seo="true" data-seo-start-page="1" data-seo-scroll="true" data-seo-scrolltop="30" data-seo-controls="1" data-seo-permalink="pretty" data-seo-pageview="true" data-container-type="div" data-repeater="default" data-post-type="post" data-order="DESC" data-orderby="date" data-offset="0" data-posts-per-page="12" data-scroll="true" data-scroll-distance="100" data-max-pages="0" data-pause-override="false" data-pause="false" data-button-label="Older Posts" data-transition="none"></div><noscript><div class="alm-listing alm-noscript"><div class="alm-reveal"><li style="padding:0px;">
   <h3><a href="https://ansonrecord.com/news/9632/new-rules" title="&#8212; NEW RULES &#8212;">&#8212; NEW RULES &#8212;</a></h3>
   <p class="entry-meta">March 17, 2020</p>
   <div class="mh-excerpt"><p>Food Programs Anson County Schools Child Nutrition Department Student Meals Distribution Schedule Update For March 20, 23, 24, 25: Lunch may be picked up from 11:00 &#8211; 12:30 pm at Wadesboro Elementary School Breakfast for <a class="mh-excerpt-more" href="https://ansonrecord.com/news/9632/new-rules" title="&#8212; NEW RULES &#8212;">[&#8230;]</a></p>
</div>

</li><li style="padding:0px;">
   <h3><a href="https://ansonrecord.com/uncategorized/9631/faith-calendar-20" title="Faith Calendar">Faith Calendar</a></h3>
   <p class="entry-meta">March 17, 2020</p>
   <div class="mh-excerpt"><p>Due to COVID-19, all church events are subject to change or cancellation. We strongly urge contacting the host organization before attending any listed event. Wednesday, March 18 New Life Ministries Pentecostal hosts noonday prayer every <a class="mh-excerpt-more" href="https://ansonrecord.com/uncategorized/9631/faith-calendar-20" title="Faith Calendar">[&#8230;]</a></p>
</div>

</li><li style="padding:0px;">
   <h3><a href="https://ansonrecord.com/news/9630/9630" title=""></a></h3>
   <p class="entry-meta">March 17, 2020</p>
   <div class="mh-excerpt"><p>Due to COVID-19, all events are subject to change or cancellation Wednesday, March 18 Story Time from 10 am &#8211; 10:30 a.m. at the Early Childhood Resource Center in the Anson County Partnership for Children <a class="mh-excerpt-more" href="https://ansonrecord.com/news/9630/9630" title="">[&#8230;]</a></p>
</div>

</li><li style="padding:0px;">
			<div style="height:248px;">
            <a href="https://ansonrecord.com/news/9629/anson-county-does-its-best-to-prepare" title="Anson County does its best to prepare">
			                           <img src="https://s24519.pcdn.co/wp-content/uploads/2020/03/web1_CORONAVIRUS4-326x245.jpeg" alt="Anson County does its best to prepare">
                          </a>
</div>			
   <h3><a href="https://ansonrecord.com/news/9629/anson-county-does-its-best-to-prepare" title="Anson County does its best to prepare">Anson County does its best to prepare</a></h3>
   <p class="entry-meta">March 17, 2020</p>
   <div class="mh-excerpt"><p>ANSON COUNTY: COVID-19 is a coronavirus, which is part of the same family of diseases as the common cold and SARS. Though highly infectious, most victims of COVID-19 display mild to moderate symptoms such as <a class="mh-excerpt-more" href="https://ansonrecord.com/news/9629/anson-county-does-its-best-to-prepare" title="Anson County does its best to prepare">[&#8230;]</a></p>
</div>

</li><li style="padding:0px;">
   <h3><a href="https://ansonrecord.com/news/9627/letter-from-the-town-manager" title="Letter from the Town Manager">Letter from the Town Manager</a></h3>
   <p class="entry-meta">March 17, 2020</p>
   <div class="mh-excerpt"><p>The top priority for the Town of Wadesboro is and always will be the safety and security of the community. As such, Town officials are taking the recent developments concerning COVID-19 into consideration as we <a class="mh-excerpt-more" href="https://ansonrecord.com/news/9627/letter-from-the-town-manager" title="Letter from the Town Manager">[&#8230;]</a></p>
</div>

</li><li style="padding:0px;">
			<div style="height:248px;">
            <a href="https://ansonrecord.com/news/9626/anson-county-schools-to-close-for-at-least-two-weeks" title="Anson County Schools to close for at least two weeks">
			                           <img src="https://s24519.pcdn.co/wp-content/uploads/2020/03/web1_anson-middle-school-1-326x245.jpg" alt="Anson County Schools to close for at least two weeks">
                          </a>
</div>			
   <h3><a href="https://ansonrecord.com/news/9626/anson-county-schools-to-close-for-at-least-two-weeks" title="Anson County Schools to close for at least two weeks">Anson County Schools to close for at least two weeks</a></h3>
   <p class="entry-meta">March 17, 2020</p>
   <div class="mh-excerpt"><p>Update: Wadesboro Elementary School will serve as a meal site for children up to the age of 18 years old and/or currently enrolled in Anson County Schools beginning Wednesday, March 18. Parents and community volunteers <a class="mh-excerpt-more" href="https://ansonrecord.com/news/9626/anson-county-schools-to-close-for-at-least-two-weeks" title="Anson County Schools to close for at least two weeks">[&#8230;]</a></p>
</div>

</li><li style="padding:0px;">
			<div style="height:248px;">
            <a href="https://ansonrecord.com/news/9624/state-of-education-in-anson-county-discussed-at-luncheon" title="state of education in Anson County discussed at luncheon">
			                           <img src="https://s24519.pcdn.co/wp-content/uploads/2020/03/web1_4-4-326x245.jpg" alt="state of education in Anson County discussed at luncheon">
                          </a>
</div>			
   <h3><a href="https://ansonrecord.com/news/9624/state-of-education-in-anson-county-discussed-at-luncheon" title="state of education in Anson County discussed at luncheon">state of education in Anson County discussed at luncheon</a></h3>
   <p class="entry-meta">March 17, 2020</p>
   <div class="mh-excerpt"><p>WADESBORO- Representatives from Anson County Partnership for Children, Anson County Schools, and South Piedmont Community spoke at the State of Education Luncheon on the unique challenges and opportunities they face as well as how all <a class="mh-excerpt-more" href="https://ansonrecord.com/news/9624/state-of-education-in-anson-county-discussed-at-luncheon" title="state of education in Anson County discussed at luncheon">[&#8230;]</a></p>
</div>

</li><li style="padding:0px;">
			<div style="height:248px;">
            <a href="https://ansonrecord.com/news/9619/incident-reports-2" title="Incident reports">
			                           <img src="https://s24519.pcdn.co/wp-content/uploads/2020/03/web1_ratliff-326x245.jpg" alt="Incident reports">
                          </a>
</div>			
   <h3><a href="https://ansonrecord.com/news/9619/incident-reports-2" title="Incident reports">Incident reports</a></h3>
   <p class="entry-meta">March 17, 2020</p>
   <div class="mh-excerpt"><p>WADESBORO- At 9:05 a.m. on Monday, March 9 a warrant was served to Shiya Demesa Threatt. She was arrested at the Magistrates Office in Wadesboro and charged with Misdemeanor Simple Assault. Threatt was also given <a class="mh-excerpt-more" href="https://ansonrecord.com/news/9619/incident-reports-2" title="Incident reports">[&#8230;]</a></p>
</div>

</li><li style="padding:0px;">
			<div style="height:248px;">
            <a href="https://ansonrecord.com/uncategorized/9616/coronavirus-and-other-trials-call-for-ambassadors-for-christ" title="Coronavirus And Other Trials Call For Ambassadors For Christ">
			                           <img src="https://s24519.pcdn.co/wp-content/uploads/2020/03/web1_Bo-Wagner-2-326x245.jpg" alt="Coronavirus And Other Trials Call For Ambassadors For Christ">
                          </a>
</div>			
   <h3><a href="https://ansonrecord.com/uncategorized/9616/coronavirus-and-other-trials-call-for-ambassadors-for-christ" title="Coronavirus And Other Trials Call For Ambassadors For Christ">Coronavirus And Other Trials Call For Ambassadors For Christ</a></h3>
   <p class="entry-meta">March 17, 2020</p>
   <div class="mh-excerpt"><p>Rocks and minerals are rather ubiquitous at our church, being found everywhere from the name of the church to a loop off of the driveway to the watercourses and all the way into my office. <a class="mh-excerpt-more" href="https://ansonrecord.com/uncategorized/9616/coronavirus-and-other-trials-call-for-ambassadors-for-christ" title="Coronavirus And Other Trials Call For Ambassadors For Christ">[&#8230;]</a></p>
</div>

</li><li style="padding:0px;">
   <h3><a href="https://ansonrecord.com/news/9614/anson-county-partnership-for-children-postpones-all-public-events" title="Anson County Partnership for Children postpones all public events">Anson County Partnership for Children postpones all public events</a></h3>
   <p class="entry-meta">March 17, 2020</p>
   <div class="mh-excerpt"><p>In efforts to keep our community and staff safe during this time, the Anson County Partnership will be postponing ALL public activities for the next eight weeks, this includes but is not limited to childcare <a class="mh-excerpt-more" href="https://ansonrecord.com/news/9614/anson-county-partnership-for-children-postpones-all-public-events" title="Anson County Partnership for Children postpones all public events">[&#8230;]</a></p>
</div>

</li><li style="padding:0px;">
   <h3><a href="https://ansonrecord.com/news/9613/netc-to-hold-blood-drive" title="NETC to Hold Blood Drive">NETC to Hold Blood Drive</a></h3>
   <p class="entry-meta">March 17, 2020</p>
   <div class="mh-excerpt"><p>Northeastern Technical College (NETC) Student Government Association will host an American Red Cross Blood Drive on Tuesday, March 24, from 10 a.m. until 4 p.m. in the auditorium of the Cheraw campus. Walk-in donations will <a class="mh-excerpt-more" href="https://ansonrecord.com/news/9613/netc-to-hold-blood-drive" title="NETC to Hold Blood Drive">[&#8230;]</a></p>
</div>

</li><li style="padding:0px;">
			<div style="height:248px;">
            <a href="https://ansonrecord.com/news/9612/hiring-opportunity-for-anson-residents" title="Hiring opportunity for Anson residents">
			                           <img src="https://s24519.pcdn.co/wp-content/uploads/2020/03/web1_Gordmans-Storefront-326x245.jpg" alt="Hiring opportunity for Anson residents">
                          </a>
</div>			
   <h3><a href="https://ansonrecord.com/news/9612/hiring-opportunity-for-anson-residents" title="Hiring opportunity for Anson residents">Hiring opportunity for Anson residents</a></h3>
   <p class="entry-meta">March 17, 2020</p>
   <div class="mh-excerpt"><p>HOUSTON &#8211; February 3, 2020 &#8211; #GotItAtGordmans means you can get a great new job and your favorite brands at your hometown&#8217;s newest store, Gordmans. The apparel and home d&#233;cor retailer is now hiring at <a class="mh-excerpt-more" href="https://ansonrecord.com/news/9612/hiring-opportunity-for-anson-residents" title="Hiring opportunity for Anson residents">[&#8230;]</a></p>
</div>

</li></div></div><div class="alm-paging" style="opacity: 1">Pages: <span class="page"><u>1</u></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/2">2</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/3">3</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/4">4</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/5">5</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/6">6</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/7">7</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/8">8</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/9">9</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/10">10</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/11">11</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/12">12</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/13">13</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/14">14</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/15">15</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/16">16</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/17">17</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/18">18</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/19">19</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/20">20</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/21">21</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/22">22</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/23">23</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/24">24</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/25">25</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/26">26</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/27">27</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/28">28</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/29">29</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/30">30</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/31">31</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/32">32</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/33">33</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/34">34</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/35">35</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/36">36</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/37">37</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/38">38</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/39">39</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/40">40</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/41">41</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/42">42</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/43">43</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/44">44</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/45">45</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/46">46</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/47">47</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/48">48</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/49">49</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/50">50</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/51">51</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/52">52</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/53">53</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/54">54</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/55">55</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/56">56</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/57">57</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/58">58</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/59">59</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/60">60</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/61">61</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/62">62</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/63">63</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/64">64</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/65">65</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/66">66</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/67">67</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/68">68</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/69">69</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/70">70</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/71">71</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/72">72</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/73">73</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/74">74</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/75">75</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/76">76</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/77">77</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/78">78</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/79">79</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/80">80</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/81">81</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/82">82</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/83">83</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/84">84</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/85">85</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/86">86</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/87">87</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/88">88</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/89">89</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/90">90</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/91">91</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/92">92</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/93">93</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/94">94</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/95">95</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/96">96</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/97">97</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/98">98</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/99">99</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/100">100</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/101">101</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/102">102</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/103">103</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/104">104</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/105">105</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/106">106</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/107">107</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/108">108</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/109">109</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/110">110</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/111">111</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/112">112</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/113">113</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/114">114</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/115">115</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/116">116</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/117">117</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/118">118</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/119">119</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/120">120</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/121">121</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/122">122</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/123">123</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/124">124</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/125">125</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/126">126</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/127">127</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/128">128</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/129">129</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/130">130</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/131">131</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/132">132</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/133">133</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/134">134</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/135">135</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/136">136</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/137">137</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/138">138</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/139">139</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/140">140</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/141">141</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/142">142</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/143">143</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/144">144</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/145">145</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/146">146</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/147">147</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/148">148</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/149">149</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/150">150</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/151">151</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/152">152</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/153">153</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/154">154</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/155">155</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/156">156</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/157">157</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/158">158</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/159">159</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/160">160</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/161">161</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/162">162</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/163">163</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/164">164</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/165">165</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/166">166</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/167">167</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/168">168</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/169">169</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/170">170</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/171">171</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/172">172</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/173">173</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/174">174</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/175">175</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/176">176</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/177">177</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/178">178</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/179">179</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/180">180</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/181">181</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/182">182</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/183">183</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/184">184</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/185">185</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/186">186</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/187">187</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/188">188</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/189">189</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/190">190</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/191">191</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/192">192</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/193">193</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/194">194</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/195">195</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/196">196</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/197">197</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/198">198</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/199">199</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/200">200</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/201">201</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/202">202</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/203">203</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/204">204</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/205">205</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/206">206</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/207">207</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/208">208</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/209">209</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/210">210</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/211">211</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/212">212</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/213">213</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/214">214</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/215">215</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/216">216</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/217">217</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/218">218</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/219">219</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/220">220</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/221">221</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/222">222</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/223">223</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/224">224</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/225">225</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/226">226</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/227">227</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/228">228</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/229">229</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/230">230</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/231">231</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/232">232</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/233">233</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/234">234</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/235">235</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/236">236</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/237">237</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/238">238</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/239">239</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/240">240</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/241">241</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/242">242</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/243">243</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/244">244</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/245">245</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/246">246</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/247">247</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/248">248</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/249">249</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/250">250</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/251">251</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/252">252</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/253">253</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/254">254</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/255">255</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/256">256</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/257">257</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/258">258</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/259">259</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/260">260</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/261">261</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/262">262</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/263">263</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/264">264</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/265">265</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/266">266</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/267">267</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/268">268</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/269">269</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/270">270</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/271">271</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/272">272</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/273">273</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/274">274</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/275">275</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/276">276</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/277">277</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/278">278</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/279">279</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/280">280</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/281">281</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/282">282</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/283">283</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/284">284</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/285">285</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/286">286</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/287">287</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/288">288</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/289">289</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/290">290</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/291">291</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/292">292</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/293">293</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/294">294</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/295">295</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/296">296</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/297">297</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/298">298</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/299">299</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/300">300</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/301">301</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/302">302</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/303">303</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/304">304</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/305">305</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/306">306</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/307">307</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/308">308</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/309">309</a></span><span class="page"><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/310">310</a></span><span><a href="https://ansonrecord.com/opinion/letters/8984/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing/page/310">Last Page</a></span></div></noscript><div class="alm-btn-wrap" style="visibility: hidden;"><button class="alm-load-more-btn more " rel="next">Older Posts</button></div></div></div></div>	</aside>	</div>
    </div>
<footer class="mh-footer" itemscope="itemscope" itemtype="http://schema.org/WPFooter">
<div class="mh-container mh-container-inner mh-footer-widgets mh-row clearfix">
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-1">
<div id="media_image-2" class="mh-footer-widget widget_media_image"><a href="http://championcarolinas.com"><img width="300" height="81" src="https://s24519.pcdn.co/wp-content/uploads/2018/02/championwhite-300x81.png" class="image wp-image-6022  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" /></a></div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-2">
<div id="nav_menu-2" class="mh-footer-widget widget_nav_menu"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner">General Information</span></h6><div class="menu-general-information-container"><ul id="menu-general-information" class="menu"><li id="menu-item-6038" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6038"><a href="https://ansonrecord.com/advertise">Advertise With Us</a></li>
<li id="menu-item-6039" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6039"><a href="https://ansonrecord.com/privacy-policy">Privacy Policy</a></li>
<li id="menu-item-6040" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6040"><a href="http://championcarolinas.com/terms">Terms Of Service</a></li>
<li id="menu-item-6077" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6077"><a href="https://ansonrecord.com/sign-up-for-notices">Sign Up For Notices</a></li>
</ul></div></div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-3">
		<div id="recent-posts-2" class="mh-footer-widget widget_recent_entries">		<h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner">Recent Articles</span></h6>		<ul>
											<li>
					<a href="https://ansonrecord.com/news/9632/new-rules">&#8212; NEW RULES &#8212;</a>
									</li>
											<li>
					<a href="https://ansonrecord.com/uncategorized/9631/faith-calendar-20">Faith Calendar</a>
									</li>
											<li>
					<a href="https://ansonrecord.com/news/9630/9630">(no title)</a>
									</li>
											<li>
					<a href="https://ansonrecord.com/news/9629/anson-county-does-its-best-to-prepare">Anson County does its best to prepare</a>
									</li>
											<li>
					<a href="https://ansonrecord.com/news/9627/letter-from-the-town-manager">Letter from the Town Manager</a>
									</li>
					</ul>
		</div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-4">
<div id="text-2" class="mh-footer-widget widget_text"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner">Contact</span></h6>			<div class="textwidget"><p><strong>Call:</strong><br />
T:704-694-2161<br />
F:704-694-7060<br />
<strong>Mail:</strong><br />
123 E. Martin St. Suite 400,<br />
Wadesboro NC, 28170</p>
</div>
		</div><div id="custom_html-10" class="widget_text mh-footer-widget widget_custom_html"><div class="textwidget custom-html-widget"><script type="text/javascript">
(function() {var s=document.createElement('script'); s.type='text/javascript'; s.async=true; s.src='//www.liqwid.net/?key=031A-9BE8-85CE-D8C0';var x=document.getElementsByTagName('script')[0];x.parentNode.insertBefore(s,x);})();
</script>
<script src="//www.queryly.com/js/queryly.v4.js"></script>
<script>
    var elem = document.createElement("div");
    elem.innerHTML = '<label for="queryly_toggle"><img class="queryly_search_button" style="z-index:9999999;vertical-align:middle;float:right;width: 30px;cursor: pointer;background: #111;border-left:1px solid #ccc;padding: 5px;margin-right: 0px;right:0;position:absolute;" src="//www.queryly.com/images/whitesearchicon.png"></label>';
    document.querySelector('#mega-menu-wrap-mh_main_nav').insertBefore(elem, document.querySelector('#mega-menu-wrap-mh_main_nav').childNodes[0] || null);

    var mobileelem = document.createElement("div");
    mobileelem.innerHTML = '<label for="queryly_toggle"><img class="queryly_search_button_mobile" style = "display:none;z-index:9999999;vertical-align:middle;float:right;width: 30px;cursor: pointer;background: #111;border-right:1px solid #ccc;padding: 5px;margin-right: 0px;right:42px;position:relative;top:-42px;" src = "//www.queryly.com/images/whitesearchicon.png" ></label><style>@media (max-width: 630px) { .queryly_search_button_mobile {display: block !important;}}</style>';
    document.querySelector('.mh-main-nav-wrap').insertBefore(mobileelem, document.querySelector('.mh-main-nav-wrap').childNodes[0] || null);

    queryly.init('44d25eaf572e4960', document.querySelectorAll('.mh-container-outer'), true);
</script>
</div></div></div>
</div>
</footer>
<div class="mh-copyright-wrap">
	<div class="mh-container mh-container-inner clearfix">
		<p class="mh-copyright">
			2018 Champion Media		</p>
	</div>
</div>
<a href="#" class="mh-back-to-top"><i class="fa fa-chevron-up"></i></a>
</div><!-- .mh-container-outer -->
		<script type="text/javascript">
			var _gaq = _gaq || [];
			_gaq.push(['_setAccount', 'UA-6686294-30']);
						_gaq.push(['_trackPageview']);
			(function() {
			 var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
			 ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
			 var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
			})();
		</script>
<script type="text/javascript" src="//launch.newsinc.com/js/embed.js" id="_nw2e-js"></script><script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"ansonrecord"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s24519.pcdn.co/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"8984 https:\/\/ansonrecord.com\/?p=8984","disqusShortname":"ansonrecord","disqusTitle":"Drawing a parallel between \u2018Sound of Music\u2019 and impeachment hearing","disqusUrl":"https:\/\/ansonrecord.com\/opinion\/letters\/8984\/drawing-a-parallel-between-sound-of-music-and-impeachment-hearing","postId":"8984"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s24519.pcdn.co/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.17'></script>
<script type='text/javascript' src='https://s24519.pcdn.co/wp-includes/js/comment-reply.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://s24519.pcdn.co/wp-includes/js/hoverIntent.min.js?ver=1.8.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var megamenu = {"timeout":"300","interval":"100"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s24519.pcdn.co/wp-content/plugins/megamenu/js/maxmegamenu.js?ver=2.7.4'></script>
<script type='text/javascript' src='https://s24519.pcdn.co/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var alm_localize = {"ajaxurl":"https:\/\/ansonrecord.com\/wp-admin\/admin-ajax.php","alm_nonce":"e36196fd38","pluginurl":"https:\/\/ansonrecord.com\/wp-content\/plugins\/ajax-load-more","scrolltop":"false","speed":"200","ga_debug":"false","results_text":"Viewing {post_count} of {total_posts} results.","no_results_text":"No results found.","alm_debug":""};
var ajax_load_more_vars = {"id":"ajax-load-more"};
var ajax_load_more_2275609599_vars = {"id":"2275609599"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s24519.pcdn.co/wp-content/plugins/ajax-load-more/core/dist/js/ajax-load-more.min.js?ver=5.2.0'></script>
<script type='text/javascript' src='https://s24519.pcdn.co/wp-content/plugins/ajax-load-more-seo/js/alm-seo.min.js?ver=1.9.0'></script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"62f380209b","applicationID":"309219029","transactionName":"ZlNUNxdQWhZTWk0KWl8ZdwARWFsLHUpQDVJdUw==","queueTime":0,"applicationTime":280,"atts":"ShRXQV9KSRg=","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>